Home Support eCommerce Gem Product categories are initially inactive links on shop page

This topic contains 3 replies, has 2 voices, and was last updated by  Promenade Themes 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #4133

    soapeditor
    Participant

    Hello!

    When my Shop page is set to be my static homepage, and I have my product categories enabled in one of my sidebars, said product categories are not active and linked initially on my Shop homepage. Viewers first have to navigate to a product category sub-page via a product tag cloud BEFORE the category links become active and responsive. Until then the links are dead and it’s just type in the Product Category sidebar menu.

    Any suggestions on how to make sure that those product category links are live and clickable from the moment a new viewer visits my site?

    Running eCommerce Gem – 1.0.5 and liking it so far.

    #4144

    Promenade Themes
    Keymaster

    Hi @soapeditor,

    Can you please send us URL of your site?

    Please provide us screenshot of your issue as well.

    Thank you.

    #4316

    soapeditor
    Participant

    Certainly!

    URL – suzannessoaps.com

    Screen shot – notice how I've selected a category of products, but the page isn't updating to show those results - no sorting, etc.

    If I click on one of the tags at the bottom (first) then the categories menu will become active and responsive. It’s just upon initial landing on this home-shop page, that the categories are not active… Very odd…

    Thank you,

    #4327

    Promenade Themes
    Keymaster

    Hi @soapeditor,

    There is a javascript error on your site. This error is thrown by WooCommerce so category change is not working on the home page of your site.

    Please check it here http://nimb.ws/BQen8s

    Once you fix this error category change will work like inner pages.

    Thank you.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.